z Patbox, 1 rok temu, napisane w YAML.
Udostępnij
  1. # Thanks for downloading ViaVersion
  2. # Ensure you look through all these options
  3. # If you need help:
  4. # Discord - https://viaversion.com/discord
  5. # viaversion.com - Discussion tab
  6. # Docs - https://docs.viaversion.com/display/VIAVERSION/Configuration
  7. #
  8. # ----------------------------------------------------------#
  9. #                     GLOBAL OPTIONS                       #
  10. # ----------------------------------------------------------#
  11. #
  12. # Should ViaVersion check for updates?
  13. checkforupdates: true
  14. # Send the supported versions with the Status (Ping) response packet
  15. send-supported-versions: false
  16. # Block specific Minecraft protocols that ViaVersion allows
  17. # List of all Minecraft protocol versions: http://wiki.vg/Protocol_version_numbers
  18. block-protocols: []
  19. # Change the blocked disconnect message
  20. block-disconnect-msg: Uzywasz niewspieranej wersji Minecraft!
  21. # If you use ProtocolLib, we can't reload without kicking the players.
  22. # (We don't suggest using reload either, use a plugin manager)
  23. # You can customise the message we kick people with if you use ProtocolLib here.
  24. reload-disconnect-msg: Server reload, please rejoin!
  25. #
  26. # ----------------------------------------------------------#
  27. #                  GLOBAL PACKET LIMITER                   #
  28. # ----------------------------------------------------------#
  29. #
  30. #
  31. # Packets Per Second (PPS) limiter (Use -1 on max-pps and tracking-period to disable)
  32. # Clients by default send around 20-90 packets per second.
  33. #
  34. # What is the maximum per second a client can send (Use %pps to display their pps)
  35. # Use -1 to disable.
  36. max-pps: 1000
  37. max-pps-kick-msg: Wysylasz za duzo pakietow!
  38. #
  39. # We can also kick them if over a period they send over a threshold a certain amount of times.
  40. #
  41. # Period to track (in seconds)
  42. # Use -1 to disable.
  43. tracking-period: 6
  44. # How many packets per second counts as a warning
  45. tracking-warning-pps: 700
  46. # How many warnings over the interval can we have
  47. # This can never be higher than "tracking-period"
  48. tracking-max-warnings: 4
  49. tracking-max-kick-msg: Wysylasz za duzo pakietow, :(
  50. #
  51. # ----------------------------------------------------------#
  52. #                 MULTIPLE VERSIONS OPTIONS                #
  53. # ----------------------------------------------------------#
  54. #
  55. # Should we enable our hologram patch?
  56. # If they're in the wrong place enable this
  57. hologram-patch: false
  58. # This is the offset, should work as default when enabled.
  59. hologram-y: -0.96
  60. # Should we disable piston animation for 1.11/1.11.1 clients?
  61. # In some cases when firing lots of pistons it crashes them.
  62. piston-animation-patch: false
  63. # Should we fix nbt for 1.12 and above clients in chat messages (causes invalid item)
  64. chat-nbt-fix: true
  65. # Experimental - Should we fix shift quick move action for 1.12 clients (causes shift + double click not to work when moving items) (only works on 1.8-1.11.2 bukkit based servers)
  66. quick-move-action-fix: false
  67. # Should we use prefix for team colour on 1.13 and above clients
  68. team-colour-fix: true
  69. # We warn when there's a error converting from pre-1.13 to 1.13, should we suppress these? (Only suggested if spamming)
  70. suppress-1_13-conversion-errors: false
  71. # 1.13 introduced new auto complete which can trigger "Kicked for spamming" for servers older than 1.13, the following option will disable it completely.
  72. disable-1_13-auto-complete: false
  73. # The following option will delay the tab complete request in x ticks if greater than 0, if other tab-complete is received, the previous is cancelled
  74. 1_13-tab-complete-delay: 0
  75. # For 1.13 clients the smallest (1 layer) snow doesn't have collision, this will send these as 2 snowlayers for 1.13+ clients to prevent them bugging through them
  76. fix-low-snow-collision: true
  77. # In 1.14 the client page limit has been upped to 100 (from 50). Some anti-exploit plugins ban when clients go higher than 50. This option cuts edited books to 50 pages.
  78. truncate-1_14-books: true
  79. # This prevents clients using 1.9-1.13 on 1.8 servers from receiving no knockback/having velocity bugs whilst sneaking under a block.
  80. change-1_9-hitbox: false
  81. # Similar to the above, but for 1.14+ players on 1.8-1.13 servers.
  82. # WARNING: This gives 1.14+ players the ability to sneak under blocks, that players under that version cannot (sneaking in places that are only 1.5 blocks high)!
  83. # Another thing to remember is that those players might be missed by projectiles and other hits directed at the very top of their head whilst sneaking.
  84. change-1_14-hitbox: true
  85. #
  86. # Enable serverside block-connections for 1.13+ clients
  87. serverside-blockconnections: true
  88. # Sets the method for the block connections (world for highly experimental (USE AT OWN RISK) world-level or packet for packet-level)
  89. blockconnection-method: world
  90. # When activated, only the most important blocks are stored in the blockstorage. (fences, glass panes etc. won't connect to solid blocks)
  91. reduce-blockstorage-memory: false
  92. # When activated with serverside-blockconnections, flower parts with blocks above will be sent as stems
  93. # Useful for lobbyservers where users can't build and those stems are used decoratively
  94. flowerstem-when-block-above: false
  95. #
  96. # ----------------------------------------------------------#
  97. #             1.9+ CLIENTS ON 1.8 SERVERS OPTIONS          #
  98. # ----------------------------------------------------------#
  99. #
  100. # No collide options, these allow you to configure how collision works.
  101. # Do you want us to prevent collision?
  102. prevent-collision: true
  103. # If the above is true, should we automatically team players until you do?
  104. auto-team: true
  105. # When enabled if certain metadata can't be read we won't tell you about it
  106. suppress-metadata-errors: false
  107. # When enabled 1.9+ will be able to block by using shields
  108. shield-blocking: true
  109. # Enable player tick simulation, this fixes eating, drinking, nether portals.
  110. simulate-pt: true
  111. # Should we use nms player to simulate packets, (may fix anti-cheat issues)
  112. nms-player-ticking: true
  113. # Should we patch boss bars so they work? (Default: true, disable if you're having issues)
  114. bossbar-patch: true
  115. # If your boss bar flickers on 1.9+, set this to 'true'. It will keep all boss bars on 100% (not recommended)
  116. bossbar-anti-flicker: false
  117. # This will show the new effect indicator in the top-right corner for 1.9+ players.
  118. use-new-effect-indicator: true
  119. # Show the new death messages for 1.9+ on the death screen
  120. use-new-deathmessages: true
  121. # Should we cache our items, this will prevent server from being lagged out, however the cost is a constant task caching items
  122. item-cache: true
  123. # Patch the anti xray to work on 1.9+ (If your server is 1.8) This can cost more performance, so disable it if you don't use it.
  124. anti-xray-patch: true
  125. # Should we replace extended pistons to fix 1.10.1 (Only on chunk load)
  126. replace-pistons: false
  127. # What id should we replace with, default is air. (careful of players getting stuck standing on them)
  128. replacement-piston-id: 0
  129. # Force the string -> json transform
  130. force-json-transform: false
  131. # Minimize the cooldown animation in 1.8 servers
  132. minimize-cooldown: true
  133. # Left handed handling on 1.8 servers
  134. left-handed-handling: true